广告
广告
广告
广告
广告
广告
广告
广告
广告
广告
广告
广告
广告
广告
广告

您的位置: 零点财经>股票问答>技术指标相关问题解答> 如何运用MACD指标掌握买卖法则?

如何运用MACD指标掌握买卖法则?

2018-05-15 13:43:36  来源:技术指标相关问题解答  本篇文章有3066字,看完大约需要10分钟的时间

如何运用MACD指标掌握买卖法则?

时间:2018-05-15 13:43:36  来源:技术指标相关问题解答

这个问题提的非常好,很多人都会说MACD有很多买卖法则,比如金叉死叉,零轴上方的二次金叉,又称空中加油,还有底背离,顶背离等,这些说起来容易,但是真正用起来并不是那么好用。

今天就给大家分享一下macd的简单而使用的方法,为大家送上一组源码——AMCD背离与面积,只送给看懂的朋友,看不懂的就洗洗睡吧!

如何运用MACD指标掌握买卖法则?

{缠论“MACD背驰 面积”}

0;

SJV:=FINANCE(34);{每股净资产}

市净率:C/SJV,NODRAW,COLOR00FF00;

每股税后利润:=(FINANCE(1)/FINANCE(29));

市盈率:C/FINANCE(33),NODRAW,COLORFFFF00;

DIF:=EMA(CLOSE,10)-EMA(CLOSE,22);

DE:=EMA(DIF,7.5);

MACDA:=2*(DIF-DE),;

HZL:=CROSS(MACDA,0);

LZH:=CROSS(0,MACDA);

BC:=BARSLAST(HZL OR LZH)+1;

ZGHZ:=IF(MACDA>0,HHV(MACDA,BC),0);

ZGLZ:=IF(MACDA<0,LLV(MACDA,BC),0);

DRAWBAND(ZGHZ,RGB(105,77,77),0,RGB(77,77,77));

DRAWBAND(ZGLZ,RGB(80,0,0),0,RGB(66,88,66));

DIFF:EMA(CLOSE,10)-EMA(CLOSE,22),COLORFFFFFF;

DEA:EMA(DIFF,7.5),COLOR00FFFF;

MACD:2*(DIFF-DEA), COLORSTICK,LINETHICK0;

STICKLINE(MACD>0 AND MACD>REF(MACD,1),0,MACD,1.5,1),COLORRED;

STICKLINE(MACD>0 AND MACD

STICKLINE(MACD<0 AND MACD

STICKLINE(MACD<0 AND MACD>REF(MACD,1),0,MACD,1.5,0),COLORFFAAFF;

↑:TROUGHBARS(3,3,1),COLOR0000FF,NODRAW;

↓:PEAKBARS(3,3,1),COLOR00FF00,NODRAW;

低:IF(↑=0,DIFF,IF(↓<↑,TROUGH(3,3,1),REF(TROUGH(3,3,1),1))),COLOR00FFFF,NODRAW;

高:IF(↓=0,DIFF,IF(↑<↓,PEAK(3,3,1),REF(PEAK(3,3,1),1))),COLOR00FF00,NODRAW;

STICKLINE(↑=0 AND DIFF<0 AND DIFF

STICKLINE(↓=0 AND DIFF>0 AND DIFF>DEA,DIFF,0,0,0),COLOR00FF00;

DRAWTEXT(↑=0 AND DIFF<0 AND DIFF

DRAWTEXT(↓=0 AND DIFF>0 AND DIFF>DEA,DIFF,'高'),COLOR00FF00;

低位金叉:=CROSS(DIFF,DEA) AND DIFF<-0.1;

JCCOUNT:=COUNT(CROSS(DIFF,DEA),BARSLAST(DEA>=0));

二次金叉:=CROSS(DIFF,DEA) AND DEA<0 AND COUNT(JCCOUNT=2,21)=1;

AA1:=BARSLAST(REF(CROSS(DIFF,DEA),1));

底背离:=(REF(L,AA1+1)>L OR REF(C,AA1+1)>C) AND (L,DIFF)>REF((L,DIFF),AA1+1) AND CROSS(DIFF,DEA);

DRAWLINE(AA1=0,DEA,底背离,DEA,0),COLOR0000FF,LINETHICK1;

AA2:=BARSLAST(REF(CROSS(DEA,DIFF),1));

顶背离:=(REF(C,AA2+1)(H,DIFF) AND CROSS(DEA,DIFF);

DRAWLINE(AA2=0,DEA,顶背离,DEA,0),COLORGREEN,LINETHICK1;

DRAWICON(CROSS(DIFF,DEA) AND DIFF>0,DEA,36);

DRAWICON(CROSS(DEA,DIFF) AND DIFF>0,DEA,37);

DRAWICON(CROSS(DIFF,DEA) AND DIFF<0,DEA,1);

DRAWICON(二次金叉,DEA*0.9,36) ;

解盘1:=CONST(IF(MACD>0,1,0));

解盘2:=CONST(IF(MACD<0,1,0));

解盘A:=IF(解盘1=1,'【精华8个字 买小卖小,缩头缩脚】 当股价一波比一波高时,反而红柱的堆,

一堆比一堆小,证明产生了顶背离现象,应该及时卖出',

IF(解盘2=1,'【精华8个字 买小卖小,缩头缩脚】 当股价一波比一波低时,

反而绿柱的堆一堆比一堆小,证明产生了底背离,应该买进',

DRAWNULL));

DRAWTEXT_FIX((解盘1=1 OR 解盘2=1),0.16,0,0,解盘A),COLORFFEE00;

这个方法用起来简单而实用,希望能帮到这位朋友。

注:下图为一线指标用法

如何运用MACD指标掌握买卖法则?

【一线指标】

阅读了该文章的用户还阅读了

热门关键词

相关阅读

为您推荐

移动平均线
股票知识
MACD
老丁说股
热点题材
KDJ指标
读懂上市公司
成交量
股票技术指标
股票大盘
分时图
股市名家
概念股
缠中说禅
强势股
波段操作
股票盘口
短线炒股
股票趋势
涨停板
股票投资
长线炒股
股票问答
股票术语
财务分析
炒股软件
上证早知道
经济学术语
期货
股票黑马
股票震荡市场
理财
炒股知识
散户炒股
外汇
炒股战术
港股
基金
黄金




































































































































































































































































































































































































































































































































































































































相关栏目推荐

栏目导航

友情链接

网站首页
老丁说股
李大霄
严为民
股票问答
股票术语
视频教学
网站地图

copyright 2016-2019 零点财经保留所有权 鲁ICP备16025527号-1 免责声明:网站部分内容转载至网络,如有侵权请告知删除

联系QQ:253161086

零点财经保留所有权 鲁ICP备16025527号-1

免责声明:网站部分内容转载至网络,如有侵权请告知删除

联系QQ:253161086