• 黄金广告位找合作伙伴qq253161086
  • 曝光量大,位置有限
  • 黄金位置,先到先得
  • 价格便宜,童叟无欺
  • 点击联系,有询必回
  • 您的位置: 零点财经>股票问答>缠论常见问题解答> 缠论分笔主图源码分享,自己画线金钻提示

    缠论分笔主图源码分享,自己画线金钻提示

    2018-07-04 22:52:32  来源:缠论常见问题解答  本篇文章有6984字,看完大约需要23分钟的时间

    缠论分笔主图源码分享,自己画线金钻提示

    时间:2018-07-04 22:52:32  来源:缠论常见问题解答

    缠论分笔主图源码分享,自己画线金钻提示

    参数照图填写

    源码

    {今日头条,天天技术指标源码分享

    }

    MA5:MA(CLOSE,5) COLORWHITE,LINETHICK2;

    MA10:MA(CLOSE,10) COLORMAGENTA,LINETHICK1;

    MA20:MA(CLOSE,20) COLORBLUE,LINETHICK1;

    MA60:MA(CLOSE,60) COLORYELLOW,LINETHICK2;

    MA250:MA(CLOSE,250) COLORRED, LINETHICK1;

    老笔:=0;

    G:=MA(C,5);D:=MA(C,10);

    HH:=REF(H,5)=HHV(H,11);

    LL:=REF(L,5)=LLV(L,11);

    FG01:=BACKSET(HH,6)>BACKSET(HH,5) ;

    FD01:=BACKSET(LL,6)>BACKSET(LL,5) ;

    FG02:=IF(BARSLAST(FG01)=BARSLAST(FD01) AND G>D,FG01,

    IF(BARSLAST(FD01)>BARSLAST(FG01),FG01,0));

    FD02:=IF(BARSLAST(FG01)=BARSLAST(FD01) AND D>G,FD01,

    IF(BARSLAST(FG01)>BARSLAST(FD01),FD01,0));

    FG0:=FG02 AND H=HHV(H,BARSLAST(FD02));

    FD0:=FD02 AND L=LLV(L,BARSLAST(FG02));

    GP:IF(FG0,H,DRAWNULL),CIRCLEDOT,COLORCYAN;

    DP:IF(FD0,L,DRAWNULL),CIRCLEDOT,COLORCYAN;

    GQ:=L>REF(H,1) AND DAY!=REF(DAY,1);

    DQ:=H

    GQL:=REF(L,BARSLAST(GQ));

    DQH:=REF(H,BARSLAST(DQ));

    FGH:=REF(H,BARSLAST(FG0));

    FGL:=REF(L,BARSLAST(FG0));

    FGH1:=REF(H,BARSLAST(FG0)+1);

    FGL1:=REF(L,BARSLAST(FG0)+1);

    FGH2:=REF(H,BARSLAST(FG0)+2);

    FGL2:=REF(L,BARSLAST(FG0)+2);

    FDH:=REF(H,BARSLAST(FD0));

    FDL:=REF(L,BARSLAST(FD0));

    FDH1:=REF(H,BARSLAST(FD0)+1);

    FDL1:=REF(L,BARSLAST(FD0)+1);

    FDH2:=REF(H,BARSLAST(FD0)+2);

    FDL2:=REF(L,BARSLAST(FD0)+2);

    FGZH:=IF(FGL<=FGL1,FGH2,FGH1);

    FGZL:=IF(FGH1

    FDZH:=IF(FDL1>FDH,FDH,IF(FDH>=FDH1,FDH2,FDH1));

    FDZL:=IF(FDH>=FDH1,FDL2,FDL1);

    FG1:=FGH>FDZH AND FG0;

    FD1:=FDL

    FG:=FG1 AND FGH>FDH AND FGL>FDL AND FGL1>FDL;

    FD:=FD1 AND FDL

    BH0:=(H<=REF(H,1) AND L>=REF(L,1)) OR (H>=REF(H,1) AND L<=REF(L,1));

    BHG:=COUNT(BH0,BARSLAST(FD0));

    BHD:=COUNT(BH0,BARSLAST(FG0));

    BGQ:=COUNT(GQ,BARSLAST(FD0));

    BDQ:=COUNT(DQ,BARSLAST(FG0));

    BK0:=IF(BHG>0,BHG+2+老笔,IF(BHD,BHD+2+老笔,3));

    BK:=IF(BGQ,BK0-BGQ,IF(BDQ,BK0-BDQ,BK0));

    G1X:=(FG AND BARSLAST(FD)>BK);

    D1X:=(FD AND BARSLAST(FG)>BK);

    G1:=(FG0 AND REF(H,BARSLAST(FG0))>=REF(H,BARSLAST(G1X)) AND BARSLAST(D1X)>BARSLAST(G1X))

    OR (FG1 AND COUNT(GQ,BARSLAST(FD1))>0 AND REF(H,BARSLAST(FG1))>REF(H,BARSLAST(G1X)));

    D1:=(FD0 AND REF(L,BARSLAST(FD0))<=REF(L,BARSLAST(D1X)) AND BARSLAST(G1X)>BARSLAST(D1X))

    OR (FD1 AND COUNT(DQ,BARSLAST(FG1))>0 AND REF(L,BARSLAST(FD1))

    G1H:=IF(BARSLAST(D1)>BARSLAST(G1),REF(H,BARSLAST(G1)),REF(H,BARSLAST(D1))),;

    D1L:=IF(BARSLAST(G1)>BARSLAST(D1),REF(L,BARSLAST(D1)),REF(L,BARSLAST(G1)));

    G2:=G1 AND H=HHV(G1H,BARSLAST(D1)+1) AND H>REF(H,1) AND BARSLAST(D1)>BARSLAST(G1);

    D2:=D1 AND L=LLV(D1L,BARSLAST(G1)+1) AND LBARSLAST(D1);

    G3:=G2 OR (FG0 AND REF(H,BARSLAST(FG0))>REF(H,BARSLAST(G2)) AND BARSLAST(D2)>BARSLAST(G2));

    D3:=D2 OR (FD0 AND REF(L,BARSLAST(FD0))BARSLAST(D2));

    GPB:IF(G1X,H,DRAWNULL),CIRCLEDOT,COLORYELLOW;

    DPB:IF(D1X,L,DRAWNULL),CIRCLEDOT,COLORYELLOW;

    DRAWICON(CROSS(MA20,MA60),MA60*0.98,9);

    DIF:=MA(CLOSE,5)-MA(CLOSE,89);

    DIFMA:=MA(DIF,36);

    XG:=CROSS(DIF,DIFMA) AND DIF<3;

    DRAWICON(XG,H*1.03,23);

    {画线}

    NN:=G3;UU:=D3;

    L1:DRAWLINE(UU,L,NN, H,0),COLORLIGREEN;L2:DRAWLINE(NN,H,UU, L,0),COLORLIGREEN;

    {标示端点数值}

    DRAWNUMBER(L1 AND L2 AND NN ,H,H),COLORLIRED;DRAWNUMBER(L1 AND L2 AND UU ,L,L),COLORLIMAGENTA;

    {折扣价}

    DRAWICON(CURRBARSCOUNT=6,LOW*0.98,24);

    DRAWNUMBER(CURRBARSCOUNT=6,LOW*0.96,C);

    DRAWICON(CURRBARSCOUNT=11,LOW*0.98,25);

    DRAWNUMBER(CURRBARSCOUNT=11,LOW*0.96,C);

    DRAWICON(CURRBARSCOUNT=21,LOW*0.98,26);

    DRAWNUMBER(CURRBARSCOUNT=21,LOW*0.96,C);

    DRAWICON(CURRBARSCOUNT=61,LOW*0.98,27);

    DRAWNUMBER(CURRBARSCOUNT=61,LOW*0.96,C);

    DRAWICON(CURRBARSCOUNT=121,LOW*0.98,18);

    DRAWNUMBER(CURRBARSCOUNT=121,LOW*0.96,C);

    {量能平台}

    N250:=250;

    PT250:=CONST(HHVBARS(V,N250));

    T250:IF(CURRBARSCOUNT<=N250,CONST(IF(PT250=0,C,REF(C,PT250))),DRAWNULL),COLOR990000;

    IF(CURRBARSCOUNT=PT250+1,T250,DRAWNULL),CIRCLEDOT,COLORFF0000,LINETHICK2;

    DRAWTEXT(CURRBARSCOUNT=N250,T250,'250'),COLOR990000;

    N120:=120;

    PT120:=CONST(HHVBARS(V,N120));

    T120:IF(CURRBARSCOUNT<=N120,CONST(IF(PT120=0,C,REF(C,PT120))),DRAWNULL),COLORAAAA00;

    IF(CURRBARSCOUNT=PT120+1,T120,DRAWNULL),CIRCLEDOT,COLORFFFF00,LINETHICK2;

    DRAWTEXT(CURRBARSCOUNT=N120,T120,'120'),COLORAAAA00;

    N60:=60;

    PT60:=CONST(HHVBARS(V,N60));

    T60:IF(CURRBARSCOUNT<=N60,CONST(IF(PT60=0,C,REF(C,PT60))),DRAWNULL),COLOR00BB00;

    IF(CURRBARSCOUNT=PT60+1,T60,DRAWNULL),CIRCLEDOT,COLOR00FF00,LINETHICK2;

    DRAWTEXT(CURRBARSCOUNT=N60,T60,'60'),COLOR00BB00;

    N30:=30;

    PT30:=CONST(HHVBARS(V,N30));

    T30:IF(CURRBARSCOUNT<=N30,CONST(IF(PT30=0,C,REF(C,PT30))),DRAWNULL),COLOR0000CC;

    IF(CURRBARSCOUNT=PT30+1,T30,DRAWNULL),CIRCLEDOT,COLOR0000FF,LINETHICK2;

    DRAWTEXT(CURRBARSCOUNT=N30,T30,'30'),COLOR0000CC;

    N20:=20;

    PT20:=CONST(HHVBARS(V,N20));

    T20:IF(CURRBARSCOUNT<=N20,CONST(IF(PT20=0,C,REF(C,PT20))),DRAWNULL),COLORDD00DD;

    IF(CURRBARSCOUNT=PT20+1,T20,DRAWNULL),CIRCLEDOT,COLORFF00FF,LINETHICK2;

    DRAWTEXT(CURRBARSCOUNT=N20,T20,'20'),COLORDD00DD;

    N10:=10;

    PT10:=CONST(HHVBARS(V,N10));

    T10:IF(CURRBARSCOUNT<=N10,CONST(IF(PT10=0,C,REF(C,PT10))),DRAWNULL),COLOR00EEEE;

    IF(CURRBARSCOUNT=PT10+1,T10,DRAWNULL),CIRCLEDOT,COLOR00FFFF,LINETHICK2;

    DRAWTEXT(CURRBARSCOUNT=N10,T10,'10'),COLOR00EEEE;

    N5:=5;

    PT5:=CONST(HHVBARS(V,N5));

    T5:IF(CURRBARSCOUNT<=N5,CONST(IF(PT5=0,C,REF(C,PT5))),DRAWNULL),COLORFFFFFF;

    IF(CURRBARSCOUNT=PT5+1,T5,DRAWNULL),CIRCLEDOT,COLORFFFFFF,LINETHICK2;

    DRAWTEXT(CURRBARSCOUNT=N5,T5,'5'),COLORFFFFFF;

    ND:=10;

    PTD:=CONST(LLVBARS(V,ND));

    TDPX:IF(CURRBARSCOUNT<=ND,CONST(IF(PTD=0,O,REF(O,PTD))),DRAWNULL), COLOR9370DB;

    IF(CURRBARSCOUNT=PTD+1,TDPX,DRAWNULL),CIRCLEDOT, COLOR9370DB,LINETHICK2;

    DRAWTEXT(ISLASTBAR,TDPX,' 地平线10'), COLOR9370DB;

    选股公式

    缠论分笔

    主图源码
    关键字: 缠论量能
    来源:缠论常见问题解答 编辑:零点财经

    阅读了该文章的用户还阅读了

    热门关键词

    相关阅读

    为您推荐

    移动平均线
    股票知识
    MACD
    老丁说股
    热点题材
    KDJ指标
    读懂上市公司
    成交量
    股票技术指标
    股票大盘
    分时图
    股市名家
    概念股
    缠中说禅
    强势股
    波段操作
    股票盘口
    短线炒股
    股票趋势
    涨停板
    股票投资
    长线炒股
    股票问答
    股票术语
    财务分析
    炒股软件
    上证早知道
    经济学术语
    期货
    股票黑马
    股票震荡市场
    理财
    炒股知识
    散户炒股
    外汇
    炒股战术
    港股
    基金
    黄金








































































































































































































































































































































































































































































































































































































































































    相关栏目推荐

    栏目导航

    友情链接

    网站首页
    李大霄
    严为民
    股票问答
    股票术语
    网站地图

    copyright 2016-2020 零点财经保留所有权 免责声明:网站部分内容转载至网络,如有侵权请告知删除

    友链,投稿,广告请联系qq:253161086 资源合作联系:253161086

    零点财经保留所有权

    免责声明:网站部分内容转载至网络,如有侵权请告知删除

    友链,投稿,广告请联系qq:253161086