您的位置: 零点财经>股票技术指标>BOLL布林通道指标> 布林线 主图 有未来

布林线 主图 有未来

2018-05-21 14:12:39  来源:BOLL布林通道指标  本篇文章有7599字,看完大约需要25分钟的时间

布林线 主图 有未来

时间:2018-05-21 14:12:39  来源:BOLL布林通道指标

源码

BOLL中线:"BOLL-M".BOLL;

UB上轨:"BOLL-M".UB;

LB下轨:"BOLL-M".LB;

HZ:=EMA(CLOSE,10);

短波:=EMA(HZ,1),COLORRED,LINETHICK1;

中波:=EMA(HZ,26),COLORFF00FF,LINETHICK1;

均线148天:=EMA(C,148),POINTDOT,LINETHICK1,COLORGREEN;

成本:=SUM(AMOUNT,0)/SUM(VOL,0)/100,COLORYELLOW ,LINETHICK2 ;

HZ2:=EMA(HZ,8),COLORRED,LINETHICK2;

HZ4:=EMA(HZ,39),COLORGREEN,LINETHICK2;

A2:STICKLINE(短波>HZ2,短波,HZ2,3,1),COLORYELLOW;

A3:STICKLINE(中波>HZ4,中波,HZ4,3,1),COLORGREEN;

买入:=IF(CROSS(短波,HZ2),C,0);

DRAWTEXT(买入>0,LOW*0.7,'买入'),COLORYELLOW;

MA60: MA(CLOSE, 60),COLORFF00FF,POINTDOT,LINETHICK1;

VARE:=MA(100*(CLOSE-LLV(CLOSE,34))/(HHV(HIGH,34)-LLV(LOW,34)),5)-20;

VARF:=100-3*SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)+2*SMA(SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);

VAR10:=100-3*SMA((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)+2*SMA(SMA((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);

VAR11:=VARFREF(VOL,1) AND CLOSE>REF(CLOSE,1);

DRAWTEXT(VAR11 AND COUNT(VAR11,30)=1,LOW*0.85,'大资金'),LINETHICK1,COLORWHITE;

VAR12:=(HIGH+LOW+CLOSE)/3;

VAR13:=(VAR12-MA(VAR12,14))/(0.015*AVEDEV(VAR12,14));

VAR14:=(VAR12-MA(VAR12,70))/(0.015*AVEDEV(VAR12,70));

VAR15:=IF(VAR13>=150 AND VAR13<200 AND VAR14>=150 AND VAR14<200,10,0);

VAR16:=IF(VAR13<=-150 AND VAR13>-200 AND VAR14<=-150 AND VAR14>-200,-10,VAR15);

VAR17:=(CLOSE-MA(CLOSE,13))/MA(CLOSE,13)*100;

VAR18:=100-ABS(VAR17);

VAR19:=IF(VAR18<90,VAR18,100);

VAR1A:=IF(VARE>0,VARE,0);

VAR1B:=IF(VAR14>=200 AND VAR13>=150,15,IF(VAR14<=-200 AND VAR13<=-150,-15,VAR16))+60;

VAR1C:=VAR1A>48 AND VAR1B>60 AND VAR19<100;

DRAWTEXT(VAR1C AND COUNT(VAR1C,30)=1,LOW*0.85,'大笔成交') COLORWHITE;

X:=BARSLAST(REF(CROSS(C,MA(C,120)),1)) AND CROSS(MA(C,20),MA(C,120));

DRAWTEXT(X,MA(C,120)-0.13,'牛股'),COLORRED;

VAR111:=MA(LOW,1);

VAR222:=MA(HIGH,2);

VAR333:=MA(CLOSE,2);

VAR777:=REF(VAR333,1);

VAR888:=SMA(MAX(VAR333-VAR777,0),13,1)/SMA(ABS(VAR333-VAR777),13,1)*100;

VAR444:=(VAR333-LLV(VAR111,9))/(HHV(VAR222,9)-LLV(VAR111,9))*100;

VAR555:=SMA(VAR444,3,1);

【阳】:=SMA(VAR555,3,1);

Y1:=SMA(【阳】,3,1);

VAR666:=(HHV(VAR222,9)-VAR333)/(HHV(VAR222,9)-LLV(VAR111,9))*100;

【阴】:=SMA(VAR666,3,1);

Y2:=SMA(【阴】,3,1);

VARBBB:=MA(INDEXC,3)*100/MA(INDEXC,10)-100;

VAREEE:=IF(VARBBB>10,10,VARBBB);

VARFFF:=IF(VAREEE<-10,-10,VAREEE);

VAR122:=REF(VARBBB,1);

VAR133:=100*(VAR333-REF(VAR333,1))/REF(VAR333,1);

VAR144:=INDEXC;

VAR155:=REF(VAR144,1);

VAR166:=100*(VAR144-VAR155)/VAR144;

VAR177:=MA(VAR133,3);

VAR188:=MA(VAR166,3);

VAR199:=(3*CLOSE+VAR111+OPEN+HIGH)/6;

VAR1AA:=(20*VAR199+19*REF(VAR199,1)+18*REF(VAR199,2)+17*REF(VAR199,3)+16*REF(VAR199,4)+15*REF(VAR199,5)+14*REF(VAR199,6)+13*REF(VAR199,7)+12*REF(VAR199,8)+11*REF(VAR199,9)+10*REF(VAR199,10)+9*REF(VAR199,11)+8*REF(VAR199,12)+7*REF(VAR199,13)+6*REF(VAR199,14)+5*REF(VAR199,15)+4*REF(VAR199,16)+3*REF(VAR199,17)+2*REF(VAR199,18)+REF(VAR199,20))/210;

VAR1BB:=MA(VAR1AA,12);

VAR1CC:=EMA(VAR1AA,5);

VAR1DD:=ABS(VAR1AA-VAR1BB);

VAR1EE:=REF(VAR333,1)*0.015;

VAR1FF:=REF(INDEXC,1);

VAR244:=ZIG(3,10)>REF(ZIG(3,10),1) AND REF(ZIG(3,10),1)

VAR255:=ZIG(3,10)REF(ZIG(3,10),2);

VAR266:=MA(CLOSE,26);

VAR277:=VAR266+2*STD(VAR333,26);

VAR288:=VAR266-2*STD(VAR333,26);

VAR2BB:=IF(VAR244 AND VAR111

VAR2CC:=IF(VAR255*VAR111 AND VAR222>VAR277,2,VAR2BB);

VAR2DD:=IF(VAR2CC=1,80,45);

VAR2EE:=IF(VAR2CC=2,0,VAR2DD);

【强弱】:=SMA(MAX(VAR333-VAR777,0),5,1)/SMA(ABS(VAR333-VAR777),5,1)*100;

DRAWTEXT(ISLASTBAR=1 AND (CROSS(【强弱】,Y2) OR VAR2EE>45), LOW*0.80,' 短期吃货!'),COLORRED;

DRAWTEXT(ISLASTBAR=1 AND (CROSS(Y1,【强弱】) OR VAR2EE<45), LOW*0.80,' 短期出货!'),COLORGREEN;

DRAWTEXT(ISLASTBAR=1 AND VAR177>VAR188, LOW*0.70,' 强于大盘!'),COLORFF00FF;

DRAWTEXT(ISLASTBAR=1 AND VAR122>VARFFF, LOW*0.50,' 大盘下降'),COLORCCFF99;

DRAWTEXT(ISLASTBAR=1 AND VAR188>=VAR177, LOW*0.70,' 弱于大盘!'),COLORGREEN;

DRAWTEXT(ISLASTBAR=1 AND VAR1AA>VAR1BB AND VAR1DD>VAR1EE AND NOT(CROSS(75,VAR888)), LOW*0.60,' 持股待涨!'),COLOR0099FF;

DRAWTEXT(ISLASTBAR=1 AND VAR1AAVAR1EE AND NOT(CROSS(【强弱】,20)), LOW*0.60,' 下调减持!'),COLORFF9900;

DRAWTEXT(ISLASTBAR=1 AND VAR1DD<=VAR1EE, LOW*0.65,' 盘整!'),COLORFF9900;

DRAWTEXT(ISLASTBAR=1 AND (INDEXC-VAR1FF)/VAR1FF>0.075, LOW*0.90,'井喷!'),COLORRED;

低吸:0.82*MA(FORCAST(CLOSE,2),40),COLORF7E300,,POINTDOT;

满仓:0.72*MA(FORCAST(CLOSE,2),40),COLOR0000FF,,POINTDOT;

大户1:=EMA(100*(CLOSE-LLV (LOW,34))/(HHV(HIGH,34)-LLV(LOW,34)),3), COLORFF00FF,LINETHICK2;

大户:=MA(大户1,2),COLORFF00FF,LINETHICK2;

散户1:=(WINNER(C*1.1)-WINNER(C*0.9))*100;

散户:=MA(散户1,12),COLORWHITE,LINETHICK1;

VAR1:=1;

VAR5:=LLV(LOW,75);

VAR6:=HHV(HIGH,75);

VAR7:=(VAR6-VAR5)/100;

VAR8:=SMA((CLOSE-VAR5)/VAR7,20,1);

VARA:=3*VAR8-2*SMA(VAR8,15,1);

主力1:=(100-VARA)*VAR1;

主力:=MA(主力1,2),COLORRED,LINETHICK2;

游资1:=MA(WINNER(CLOSE*0.95)*100,3)*VAR1*1.1;

游资:=MA(游资1,2),COLORGREEN,LINETHICK1;

主升浪:= (CROSS(大户,主力) AND (MA(C,20)-LLV(MA(C,20),30))/ LLV(MA(C,20),30)*100<10

AND 主力>50 AND (主力-REF(主力,50)) >20 AND (C-MA(C,20))/MA(C,20)*100 <12 AND

散户<70) OR (CROSS(大户,主力) AND (MA(C,20)-LLV(MA(C,20),30))/ LLV(MA(C,20),30)*100<10

AND 主力>70 AND (主力-REF(主力,50)) >30 AND (C-MA(C,20))/MA(C,20)*100 <20 AND

散户<70 ) OR (CROSS(游资,主力) AND 大户>80 AND 散户>80 AND (REF(主力,100)-主力)/主力*100 >80) ;

DRAWTEXT(主升浪, LOW*0.95,'主升浪'),COLORRED;

大黑马飚升:= CROSS(游资,散户) AND REF(主力,5)>75 AND ((游资-REF(游资,3)) /3>8

OR (大户-REF(大户,3)) /3>7)AND (HHV(HIGH,100)-C)/C*100<40;

{股旁网-股票公式网站 www.gupang.com}

DRAWTEXT(大黑马飚升, LOW*0.95,'大黑马飚升'),COLORRED;

黑马飚升:= (CROSS(大户,散户) AND REF(主力,5)>75 AND ((游资-REF(游资,3)) /3>6

OR (大户-REF(大户,3)) /3>6)AND (HHV(HIGH,50)-C)/C*100<40) OR ( CROSS(游资,散户)

AND REF(主力,5)>50 AND ((游资-REF(游资,3)) /3>6 OR

(大户-REF(大户,3)) /3>6)AND (HHV(HIGH,50)-C)/C*100<40);

DRAWTEXT(黑马飚升, LOW*0.85,'黑马飚升'),COLORRED;

长线大黑马:= CROSS(游资,大户) AND 游资>90 AND C>REF(C,20) AND 主力<30;

DRAWTEXT(长线大黑马, LOW*0.85,'长线大黑马'),COLORRED;

VAR4:=(LOW+HIGH+CLOSE)/3;

操作:=MA(VAR4,5);

压力:=HHV(操作,60);

买:=(CROSS(游资,大户) AND 主力>80 AND ((主力-游资)<20 OR (游资-主力)<20)AND (压力-C)/C*100>30 )

OR (CROSS(游资,散户) AND 主力>80 AND ((主力-游资)<20 OR (游资-主力)<20)AND (压力-C)/C*100>30 )

AND C>REF(C,1) AND (C-LLV(C,10))/LLV(C,10)*100<35 AND (C-LLV(C,30))/LLV(C,30)*100<40;

DRAWTEXT(买, LOW*0.90,'买'),COLORRED;

总股本:=FINANCE(1)/100000000,POINTDOT,COLOR0000FF;

流通股本:=FINANCE(7)/100000000,POINTDOT,COLORYELLOW;

解禁股:=IF((流通股本-REF(流通股本,1))>0,(流通股本-REF(流通股本,1)),0),COLORYELLOW;{流通股增加}

DRAWTEXT(解禁股>0, HIGH*1.1,'解禁'),COLORGREEN;

冻结:=IF((流通股本-REF(流通股本,1))<0,(REF(流通股本,1)-流通股本),0),COLORGREEN;{流通股减少};

DRAWTEXT(冻结>0, HIGH*1.1,'冻结'),COLORGREEN;

布林线 主图 有未来

关键字: 主升浪牛股出货
来源:BOLL布林通道指标 编辑:零点财经

阅读了该文章的用户还阅读了

热门关键词

相关阅读

为您推荐

移动平均线
股票知识
MACD
老丁说股
热点题材
KDJ指标
读懂上市公司
成交量
股票技术指标
股票大盘
分时图
股市名家
概念股
缠中说禅
强势股
波段操作
股票盘口
短线炒股
股票趋势
涨停板
股票投资
长线炒股
股票问答
股票术语
财务分析
炒股软件
上证早知道
经济学术语
期货
股票黑马
股票震荡市场
理财
炒股知识
散户炒股
外汇
炒股战术
港股
基金
黄金








































































































































































































































































































































































































































































































































































































































































相关栏目推荐

栏目导航

友情链接

网站首页
李大霄
严为民
股票问答
股票术语
网站地图

copyright 2016-2020 零点财经保留所有权 免责声明:网站部分内容转载至网络,如有侵权请告知删除

友链,投稿,广告请联系qq:253161086 资源合作联系:253161086

零点财经保留所有权

免责声明:网站部分内容转载至网络,如有侵权请告知删除

友链,投稿,广告请联系qq:253161086